waituk7
By:
waituk7

Connection Refused Error

August 26, 2017 191 views
Docker DigitalOcean Ubuntu 16.04

curl: (7) Failed to connect to xx.xx.xx.xxx port 80: Connection refused

I installed the droplet and setup everything properly and the forum was working perfectly fine, until I tried to add SSL to the site by following this tutorial: https://meta.discourse.org/t/allowing-ssl-https-for-your-discourse-docker-setup/13847

After completing the process, I returned to my forum and since the site was unreachable showing:
curl: (7) Failed to connect to forum.waituk.com port 80: Connection refused

After spending whole night, I finally gave and recreated the app with One Click Install offered by Digital Ocean. I got new IP and completed everything in the One Click Install and then received following confirmation:


Thanks! Your Discourse instance is now being configured....this can take a few minutes...

If you need to re-run this script, run:
bash /var/lib/digitalocean/discourse.sh

Failed to stop lighttpd.service: Unit lighttpd.service not loaded.
Failed to execute operation: No such file or directory
Failed to start docker.service: Unit docker.service not found.
Device "docker0" does not exist.
Docker is not installed, you will need to install Docker in order to run Launcher
See https://docs.docker.com/installation/
/var/lib/digitalocean/discourse.sh: line 70: docker: command not found
/var/lib/digitalocean/discourse.sh: line 71: docker: command not found

Now you will be prompted to set your admin password. When prompted put
'xxx@xxx.com' as for the admin

/var/lib/digitalocean/discourse.sh: line 80: docker: command not found

Discourse has now been configured. You may now finish setting up Discourse
by creating an account at:
http://xx.xx.xx.xxx


And I notice the docker is missing and I am still getting the same error:

curl: (7) Failed to connect to xx.xx.xx.xxx port 80: Connection refused

So, I destroyed and created new droplet and I still got curl: (7) Failed to connect to xx.xx.xx.xxx port 80: Connection refused

Then I deactivated my whole account and signed for new account. And recreated everything from scratch, and I am still getting: curl: (7) Failed to connect to xx.xx.xx.xxx port 80: Connection refused

Even without installing anything, when I check the IP, I keep getting curl: (7) Failed to connect to xx.xx.xx.xxx port 80: Connection refused

Any help?

1 Answer

If SSL has been setup I suggest you use port 443 not port 80.
If that doesn't work still give a list of your listening ports

netstat -anltp | grep "LISTEN"
Have another answer? Share your knowledge.