Connection refused/timeout

After several days of running smoothly, My droplet suddenly started refusing connections. I am currently running 3 small python scripts that are not resource heavy.

The droplet runs Ubuntu. Everything worked great for 9 days, I was able to gain access via RDC/FTP, and view everything(script running) via droplet IP. None of that works now, and I haven’t made any changes to the droplet.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
January 9, 2023

Hi @d0acd779fe6c4a8f808a2574099668,

I’ll recommend connecting to your Droplet using the Droplet Console and seeing if everything inside is as it should be :

See if you have network access by pinging google for instance. Additionally, check your firewalls and as a whole if everything you can think of is okay with the Droplet. We can take it from there and think of next steps when this is done.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

card icon
Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Sign up
card icon
Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We’d like to help.

Learn more
card icon
Become a contributor

You get paid; we donate to tech nonprofits.

Learn more
Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow – whether you’re running one virtual machine or ten thousand.

Learn more ->
DigitalOcean Cloud Control Panel