Question

Connection refused When I using browser with other port

I can access my host with browser using 80 port, but I get Connection refused when I access my host with other port (like 8080, 81, 82…). How can I expose more port to access my services?

the output of netstat -lnp as below:

Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 127.0.0.1:9000 0.0.0.0:* LISTEN 28886/php-fpm.conf) tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1666/sshd tcp6 0 0 :::3306 :::* LISTEN 15739/docker-proxy tcp6 0 0 :::2222 :::* LISTEN 14782/docker-proxy tcp6 0 0 :::8080 :::* LISTEN 15942/docker-proxy tcp6 0 0 :::80 :::* LISTEN 15161/docker-proxy tcp6 0 0 :::22 :::* LISTEN 1666/sshd tcp6 0 0 :::443 :::* LISTEN 15150/docker-proxy


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

If you have your UFW enabled, you can open ports with the following command:

sudo ufw allow 8080

Also I can see that you are using Docker, you need to make sure that you expose the port that you are trying to access, for example:

docker run -d -p 8080:8080 ID

This would expose port 8080 on the host and forward it to the container.

Hope that this helps! Regards, Bobby