Question

Console stuck in caps lock mode?

Not sure how it happened, but my droplet’s console (the browser one) is stuck in caps lock mode. How can I get it back to normal?

Subscribe
Share

If your problem came after you copy paste in the console your public key the solution is the following:

  • make sure you don’t have the caps button on
  • keep shift key pressed while you write the word “reset” in your console After the reset command your terminal should be back to normal.

And the solution to copy paste your public key is to copy paste chunks of it, i do it in chunks no bigger than 30 characters and it work, but you need to do it a couple of times to get your whole key.

If your problem came after you copy paste in the console your public key the solution is the following:

  • make sure you don’t have the caps button on
  • keep shift key pressed while you write the word “reset” in your console After the reset command your terminal should be back to normal.

And the solution to copy paste your public key is to copy paste chunks of it, i do it in chunks no bigger than 30 characters and it work, but you need to do it a couple of times to get your whole key.

If your problem came after you copy paste in the console your public key the solution is the following:

  • make sure you don’t have the caps button on
  • keep shift key pressed while you write the word “reset” in your console After the reset command your terminal should be back to normal.

And the solution to copy paste your public key is to copy paste chunks of it, i do it in chunks no bigger than 30 characters and it work, but you need to do it a couple of times to get your whole key.

If your problem came after you copy paste in the console your public key the solution is the following:

  • make sure you don’t have the caps button on
  • keep shift key pressed while you write the word “reset” in your console After the reset command your terminal should be back to normal.

And the solution to copy paste your public key is to copy paste chunks of it, i do it in chunks no bigger than 30 characters and it work, but you need to do it a couple of times to get your whole key.

If your problem came after you copy paste in the console your public key the solution is the following:

  • make sure you don’t have the caps button on
  • keep shift key pressed while you write the word “reset” in your console After the reset command your terminal should be back to normal.

And the solution to copy paste your public key is to copy paste chunks of it, i do it in chunks no bigger than 30 characters and it work, but you need to do it a couple of times to get your whole key.

This issue was posted four years ago with over 5k views, but no solution yet… I wonder how may devs have wasted hours and ultimately ditched DigitalOcean because of this.

Yeah, this is pretty bad. Power cycle also helped me, but that’s a terrible solution for many reasons.

DigitalOcean…please get a dev on this for a day and get it resolved. This is pretty embarrassing and surprised it hasn’t been fixed in 5+ years. And if you don’t have the cycles, then release the source code for the web console you are using or point to it and let us hack at it to provide some improvement patches. Then you just have to review the code and apply. Even if it seems like a low priority, it really shouldn’t be. When you get to the point you need the console, it’s pretty terrible to be fighting caps lock constantly (esp. in pasting).

As always, love the products, but this is a bit of a failure in the table stakes of cloud VMs. <3

this happened to me while i was copy pasting a mysql DDL script. Rebooting helped.

This is happening to me also. Although it’s always been caps lock for me. Really strange.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, all

The Droplet web console provides out-of-band access and is available regardless of your network settings. It emulates the access you would have if you were sitting down with a keyboard and monitor attached to the actual server. You can use this feature to log in and revert bad settings to regain normal access.

You can also check our docs on How to Connect to Droplets with SSH:

https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/

There are two options at the bottom of the doc: Connect with OpenSSH and Connect with PuTTY

Hope that this helps! Regards, Alex

A workaround for adding your SSH key: host a Python file server, use NGrok to get public URL, fetch it from your Digital Ocean box.

# For MacOS:

mkdir /tmp/serve
cp ~/.ssh/id_rsa.pub /tmp/serve/ # Copy since ~/.ssh also contains id_rsa
cd /tmp/serve/
python -m SimpleHTTPServer 8000 # Leave this running

# Create new tab: Cmd + T
brew install ngrok # See https://dashboard.ngrok.com/get-started
ngrok http 8000 # Leave this running. Use HTTPS URL below

# From Digital Ocean box:
mkdir ~/.ssh
chmod 711 ~/.ssh

curl -s https://{ngrok id here}.ngrok.io/id_rsa.pub >> ~/.ssh/authorized_keys
chmod 600 ~/.ssh/authorized_keys

# Voilà!

You can now SSH into your box.

This is beyond useless. I can’t find any way to add an ssh key to my authorized_keys file.

this has been an issue for 4 years? typing seems fine, but copying and pasting in to the terminal changes the casing - completely unusable

this has been an issue for 4 years? typing seems fine, but copying and pasting in to the terminal changes the casing - completely unusable

Same problem here (while setting up SSH-- incredibly frustrating!)

My workaround had been to hold SHIFT for lowercase, which is fun while editing ssh_config in vim.

In case it saves someone some frustration, you can tell the console that caps lock is on with the command:

setleds -D +caps

…which will negate the confused console app. (Actual caps lock key may work, but mine is remapped to CTRL)

Oh, and yes, the problem began when I pasted my public key into the terrible console app. After failing for several minutes to configure sshd to allow password-based authentication, the ultimate solution was to put the public key in a pastebin and wget / curl it from the console.

Same problem here (while setting up SSH-- incredibly frustrating!)

My workaround had been to hold SHIFT for lowercase, which is fun while editing ssh_config in vim.

In case it saves someone some frustration, you can tell the console that caps lock is on with the command:

setleds -D +caps

…which will negate the confused console app. (Actual caps lock key may work, but mine is remapped to CTRL)

Oh, and yes, the problem began when I pasted my public key into the terrible console app. After failing for several minutes to configure sshd to allow password-based authentication, the ultimate solution was to put the public key in a pastebin and wget / curl it from the console.

Same problem here (while setting up SSH-- incredibly frustrating!)

My workaround had been to hold SHIFT for lowercase, which is fun while editing ssh_config in vim.

In case it saves someone some frustration, you can tell the console that caps lock is on with the command:

setleds -D +caps

…which will negate the confused console app. (Actual caps lock key may work, but mine is remapped to CTRL)

Oh, and yes, the problem began when I pasted my public key into the terrible console app. After failing for several minutes to configure sshd to allow password-based authentication, the ultimate solution was to put the public key in a pastebin and wget / curl it from the console.

Same problem here (while setting up SSH-- incredibly frustrating!)

My workaround had been to hold SHIFT for lowercase, which is fun while editing ssh_config in vim.

In case it saves someone some frustration, you can tell the console that caps lock is on with the command:

setleds -D +caps

…which will negate the confused console app. (Actual caps lock key may work, but mine is remapped to CTRL)

Oh, and yes, the problem began when I pasted my public key into the terrible console app. After failing for several minutes to configure sshd to allow password-based authentication, the ultimate solution was to put the public key in a pastebin and wget / curl it from the console.

Same problem here (while setting up SSH-- incredibly frustrating!)

My workaround had been to hold SHIFT for lowercase, which is fun while editing ssh_config in vim.

In case it saves someone some frustration, you can tell the console that caps lock is on with the command:

setleds -D +caps

…which will negate the confused console app. (Actual caps lock key may work, but mine is remapped to CTRL)

Oh, and yes, the problem began when I pasted my public key into the terrible console app. After failing for several minutes to configure sshd to allow password-based authentication, the ultimate solution was to put the public key in a pastebin and wget / curl it from the console.