Question

Contact Form 7 Not Sending Emails on Wordpress

  • Posted March 4, 2014

I just moved to a new droplet and my contact form on wordpress is not sending emails. I configured exim per the support article, set up this spf record (TXT @ v=spf1 ip4:mydomainip -all)

Any thoughts?

Subscribe
Share

Hello, I registered with you to have an IP address for the Platincoin Blockchain but so far nothing is working. I would like to stay subscribed to Digital Ocean but I would like everything to work otherwise it is useless. Thank you for solving this problem which comes from you. Cordially Isabelle Sanchez

Bonjour,

Je me suis inscrite chez vous pour avoir une adresse IP pour la Blockchaine de Platincoin mais à ce jour rien ne fonctionne.

J’aimerais rester abonnée chez Digital Océan mais j’aimerais bien que tout marche sinon ça ne sert à rien.

Merci de régler ce problème qui vient de chez vous.

Cordialement

Isabelle Sanchez


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You can’t run multiple MTA. You already have something listening on port 25.

Check your firewall settings: <br>sudo iptables -L <br> <br>If you have issues with the configuration try Exim’s configuration tool: <br>sudo dpkg-reconfigure exim4-config

Now I am getting these errors: <br> <br>2014-03-04 17:32:46 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (3 more tries) <br>2014-03-04 17:33:15 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (5 more tries) <br>2014-03-04 17:33:16 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (2 more tries) <br>2014-03-04 17:33:45 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (4 more tries) <br>2014-03-04 17:33:46 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (1 more try) <br>2014-03-04 17:34:15 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (3 more tries) <br>2014-03-04 17:34:16 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned <br>2014-03-04 17:34:45 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (2 more tries) <br>2014-03-04 17:35:15 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: waiting 30s before trying again (1 more try) <br>2014-03-04 17:35:45 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned <br>

I also realized that my install of exim gave this error at some point: <br> <br>postmulti: fatal: config variable inet_interfaces: host not found: loopback-only <br> [ OK ] <br>

I get this error before the queue ends <br> <br>R=dnslookup T=remote_smtp defer (111): Connection refused <br>

Check the Exim4 Logs to see what’s the problem, there might be something missing on the Exim4 config: <br>sudo tail /var/log/exim4/mainlog