Question

CoreOs and ssh login failing

  • Posted October 23, 2014

Howdy !

ssh login works for all distros except for coreos. Do I need to use a specific algo or a certain key length for coreos ?

Thanx, Matthias

Subscribe
Share

Run ssh with the ‘-v’ flag to see where it fails. Could be that your access rights are wrong. On your DO instance it should look like this:

269268 4 drwx------ 2 core core 4096 Dec 18 18:58 .ssh

ls -l .ssh/ total 4 -rw------- 1 core core 397 Dec 18 18:58 authorized_keys

For me, I tried to login as [core] user, and failed to get in.

No response from my droplets, saying “Connection timed out”. I also added my SSH pub key to my account.

What’s wrong with me?

Thanks, Joshua

I can’t login either. This is what I’m typing. :/

ssh core@1.2.3.4

But, all I get is: “ssh: connect to host 1.2.3.4 port 22: Operation timed out”. (Obviously, 1.2.3.4 is my droplet’s IP address.)

I clicked the button to add my id_ecdsa.pub key to the server.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Your existing SSH keys should work fine on CoreOS. What user are you connecting as? Try using core instead of root.

Your existing SSH keys should work fine on CoreOS. What user are you connecting as? Try using core instead of root.

Your existing SSH keys should work fine on CoreOS. What user are you connecting as? Try using core instead of root.

Your existing SSH keys should work fine on CoreOS. What user are you connecting as? Try using core instead of root.

I have the similar problem.

It stucks at expecting SSH2_MSG_KEX_DH_GEX_REPLY.

chuck@chuck-OptiPlex-3010:~/.ssh % ssh -v root@128.199.68.147 OpenSSH_5.9p1 Debian-5ubuntu1.4, OpenSSL 1.0.1 14 Mar 2012 debug1: Reading configuration data /home/chuck/.ssh/config debug1: /home/chuck/.ssh/config line 48: Applying options for * debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug1: Connecting to 128.199.68.147 [128.199.68.147] port 22. debug1: Connection established. debug1: identity file /home/chuck/.ssh/id_rsa type 1 debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048 debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048 debug1: identity file /home/chuck/.ssh/id_rsa-cert type -1 debug1: identity file /home/chuck/.ssh/id_dsa type 2 debug1: Checking blacklist file /usr/share/ssh/blacklist.DSA-1024 debug1: Checking blacklist file /etc/ssh/blacklist.DSA-1024 debug1: identity file /home/chuck/.ssh/id_dsa-cert type -1 debug1: identity file /home/chuck/.ssh/id_ecdsa type -1 debug1: identity file /home/chuck/.ssh/id_ecdsa-cert type -1 debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6 debug1: match: OpenSSH_6.6 pat OpenSSH* debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1.4 debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug1: kex: server->client aes128-ctr hmac-md5 none debug1: kex: client->server aes128-ctr hmac-md5 none debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP debug1: SSH2_MSG_KEX_DH_GEX_INIT sent debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

When i switch to the ‘core’ user, It stucked again!

chuck@chuck-OptiPlex-3010:~/Dropbox/Mackup/.ssh % ssh -v core@128.199.68.147 OpenSSH_5.9p1 Debian-5ubuntu1.4, OpenSSL 1.0.1 14 Mar 2012 debug1: Reading configuration data /home/chuck/.ssh/config debug1: /home/chuck/.ssh/config line 48: Applying options for * debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug1: Connecting to 128.199.68.147 [128.199.68.147] port 22. debug1: Connection established. debug1: identity file /home/chuck/.ssh/id_rsa type 1 debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048 debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048 debug1: identity file /home/chuck/.ssh/id_rsa-cert type -1 debug1: identity file /home/chuck/.ssh/id_dsa type 2 debug1: Checking blacklist file /usr/share/ssh/blacklist.DSA-1024 debug1: Checking blacklist file /etc/ssh/blacklist.DSA-1024 debug1: identity file /home/chuck/.ssh/id_dsa-cert type -1 debug1: identity file /home/chuck/.ssh/id_ecdsa type -1 debug1: identity file /home/chuck/.ssh/id_ecdsa-cert type -1 debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6 debug1: match: OpenSSH_6.6 pat OpenSSH* debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1.4 debug1: SSH2_MSG_KEXINIT sent

I just can’t figure it out what’s wrong.

Plz help!