Correct DNS configuration with ISPConfig3?

February 13, 2015 3.3k views

Hello everyone thank you in advance for your advices.
I have been trying to solve this by miself but I really can´t, need some help

I have installed ISPConfig3 with nginx following this guide "The Perfect Server - CentOS 7 x86_64 (nginx, Dovecot, ISPConfig 3)"

Then I followed the docs in here to create client, site, email domain and a mailbox ( but when I send emails, don´t reach the receiver.

I suspect that this have something to do with my dns configuration, because I can acces to roundcube with

This are my DNS records:

$TTL 1800 IN SOA 1423828442 10800 3600 604800 1800 1800 IN NS 1800 IN NS 1800 IN NS 1800 IN A 1800 IN A 1800 IN A 1800 IN MX 10

I can acces my site and with but I don´t understand the appropiate configuration in DNS to make it work (mail server)

Again thank you very much! I hope someone can help me

5 Answers

Your dns looks good.

Check your mail logs to see if any errors are showing up.

I checked /var/log/maillog and at the end there is one error

Feb 13 16:09:05 tilabmx postfix/qmgr[1104]: EAA014260D:, size=1760, nrcpt=1 (queue active)
Feb 13 16:09:05 tilabmx postfix/smtp[25443]: connect to[]:10024: Connection refused
Feb 13 16:09:05 tilabmx postfix/smtp[25443]: EAA014260D:, relay=none, delay=42538, delays=42538/0.03/0/0, dsn=4.4.1, status=deferred (connect to[]:10024: Connection refused)

Looks like email is coming but can´t reach roundcube, right? I think this is because roundcube works with SMTP right?

How can I config SMTP after the installation of roundcube?

Well this is what I think it is but I´m asking for help.

Again thank you in advance and have a great day!

Amavisd isn't running.

Just try restarting it.

With debian/ubuntu the command is
service amavis restart

Not sure about centos but
systemctl start amavisd.service

Thank you very much for your answer. Now I can send emails but I can´t receive them.
When I send an email from my gmail account I receive this:
This is the mail system at host

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system unknown user: "contacto"

Final-Recipient: rfc822;
Original-Recipient: rfc822;
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "contacto"

In ispconfig email section make sure you

  1. Under domain. Add your domain
  2. Under .Email Mailbox. Add your mailbox contacto under alias and make sure domain list your
  3. Set password
  4. Set your spam filter as needed. Usually Normal.
  5. Make sure enable receiving is checked. Save settings.

If still not working check you mail logs again. This is what it looks like your email just doesn't address just doesn't exist.

Have another answer? Share your knowledge.