Question

CORS apache linux Access-Control-Allow-Origin "*"

Can´t make Access-Control-Allow-Origin “" working, I have done the setup for making .htaccess working right, I know it´s working right because ErrorDocument 404 is working perfect, but: Header set Access-Control-Allow-Origin "” is not. I have added Header set Access-Control-Allow-Origin “*” inside etc/apache2/sites-available/000-default.conf but nothing, can you help me with this? thanks, I have read all the related support about this, tried everything but nothing.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

The mod_headers module could be disabled. Try enabling it and reload Apache.

sudo a2enmod headers
sudo service apache2 reload

If you still don’t see the header try adding it to your .htaccess file:

Header set Access-Control-Allow-Origin "*"

Thanks. It works! Setting this header -

Header always set Access-Control-Allow-Origin "*"

in apache.config file and then enabling the mod_headers module and restarting the apache2 using -

sudo a2enmod headers
sudo service apache2 reload

worked for me.

Working Thanks