Question

Could not find rake-10.3.2 in any of the sources (Bundler::GemNotFound)

  • Posted September 26, 2014

Hi,

I just created a new droplet, after configure Git, MySQL, this and that, upload my rails repository, doing bundle install, rake db:migrate and restarting Unicorn server, I get into this error:

E, [2014-09-26T11:19:22.895711 #15963] ERROR – : Could not find rake-10.3.2 in any of the sources (Bundler::GemNotFound)

I was looking over the Internet, many of the solutions just doesn’t work. The last one was getting rid of my .bundle/config file because they said it was overwriting the BUNDLE_PATH. But after doing that, running bundle, restarting, etc, the problem is still there.

It’s a preconfigured droplet with Ubuntu & Rails. Running gem env:

- GEM PATHS:
     - /usr/local/rvm/gems/ruby-2.0.0-p353
     - /usr/local/rvm/gems/ruby-2.0.0-p353@global

Seems like gems aren’t installed where they should, but I have no idea where they are really installed. Tried even with bundle install --path=/usr/local/rvm/gems/ruby-2.0.0-p353@global with the same luck.

Anyone knows what could I do or why is this happening?

Subscribe
Share

Hi,

if I understand you correctly, you had no problem doing “bundle install” and “rake db:migrate”. You got this error (GemNotFound) when you tried to access to the site?

Under which user did you run these commands? Did you try the preconfigured “rails” user? Did you change any preconfigured settings - ruby version, for example?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I am having this exact problem - been trying to solve for a couple of hours now…

Hi. Thank you for your answer.

I am using root all the time, since when I tried to use the rails preconfigured user I can’t really use any command, for example bundle:

$ bundle install
-sh: 1: bundle: not found