CPU Optimized Droplet works very slow

July 24, 2019 380 views
Big Data DigitalOcean

Hello, I was using a CPU Optimized Droplet. At first month it worked very fast with a low amount of information for example a process that I developed, it took a maximum of 2 minutes to to deliver results. But the second month with more information, it began to work very slow. The customers could not use the application and the process took more than 30 minutesSo I need your help

2 Answers

Hello,

Have you tried optimizing the process that you are running so that it does not have to process that much information all at once? It is quite logical that if you need to process more data that the processes would take longer.

Also maybe it is not a bad idea to add some extra resources to the droplet and check if this has a positive impact on the execution time.

Hope that this helps!
Bobby

  • Hi,

    Yes, I have optimized the process and also changed the size of the droplet (from 8GB in RAM, 4vCPU and 50 GB to 16 GB in RAM, 8 vCPU and 100 GB) and I am sorry, I need to clarify that the size of the information for processing is the same as the beginning. The only difference is that, as It was in a database, at first month I had little information, but right now I have a lot of information.

    • Hello,

      Yes adding more data in your database would mean that there would be more data would have to be processed so that’s probably why there is some delay after the growth of the database. What I would suggest is adding indexes to the database, this should drastically improve your selects.

      Also while running those processes, do you see any RAM or CPU spikes on your server?

      Regards,
      Bobby

      • Hello Bobby, thanks for your answers.

        Ok, but the information size for processing is the same as the beginning. For example I process 400K of daily information and record it in my database. This action is performed daily and in a divided way (from 100k in 100k in different time - Processing: 100k, next Processing: 100k, etc.). And also I have indexes in my database.

        Yes, I can see CPU and load average spikes when processing starts.

        Regards,
        Andy

Faced similar issue on one of my webapp on bluemods.com. The server worked fine for the first few months but as the number of user grew the speed became really slow. All this while the RAM steady at 50%.

Have another answer? Share your knowledge.