Question

Created droplet with ssh and still asking for password

  • Posted September 18, 2013

I create droplet and tap on pre-built-ssh key. When logging in to ssh root@<ip> i’am getting The authenticity of host ‘<ip> (<ip>)’ can’t be established. RSA key fingerprint is <fingerprint>. And then asking for password… Can you please help?

Woking on macOS x

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’m had the same problem. When I ran cat /root/.ssh/authorized_keys I saw the correct ssh key. I fixed it using an entry in my ssh config that looks like this: <br> <br>#DIGITALOCEAN <br>Host do-WEBPROJECTS <br>HostName <ip of my droplet> <br>User root <br>IdentityFile ~/.ssh/id_rsa_DIGITALOCEAN <br> <br>On the command line I enter, “ssh do-WEBPROJECTS”. My Mac prompts me for the passphrase to the ssh key… and I’m in.

I have same problem. SSH key is not working. When I try ssh root@… it keeps asking me for a root password.

I do not wont to change anything on server setup in order to use this (ssh keys).

If there is a option during setup that says use this key then why is it not working?

In the above, HostName is the IP address of the Droplet.

What user are you connecting as and if you input the password and run <code>cat /home/user/.ssh/authorized_keys</code> what does it output? <br> <br>Please pastebin the output of <code>tail /var/log/auth.log</code> as well.

And then i input ‘yes’ it asks for password :/

The authenticity of host ‘ip (ip)’ can’t be established. <br>RSA key fingerprint is 0a:22:b9:01:5f:2c:43:b4:5d:db:ba:ec:7c:76:fe:cd. <br>Are you sure you want to continue connecting (yes/no)?

<strong>When i try to login through ssh, my fingerprints are different…</strong> <br> <br>What do you mean?

No, i use independent rsa key, and config file inside .ssh directory <br>and this independent rsa public key of course matches DO account ssh key. <br> <br>When i try to login through ssh, my fingerprints are different…

Does the SSH key you added to your DigitalOcean account match the output of <code>cat ~/.ssh/id_rsa.pub</code> <strong>on your mac</strong>?