Creating new droplet with SSH keys didn't work

February 8, 2015 2.3k views

I followed this guide to the letter:

However after creating the droplet (Step 5) I tried to log into my server but got this:

forrester@**:~$ ssh root@********
Agent admitted failure to sign using the key.
root@***********'s password:
Permission denied, please try again

I tried my SSH key passphrase as the password but as you can see it didn't work. Seeing as I opted into the SSH key I never got an email with a password. How can I fix this?

  • Running ssh -vv root@******** will give you more verbose error output. That might help figure out the issue here. If you created the SSH key in a non-standard location, remember to pass the path to the key: ssh -i /path/to/id_rsa root@********

  • Soluction in terminal for error

    Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).

    ssh-keygen -f " ~/.ssh/known_hosts" -R

    xx - ip host

2 Answers

I just figured out the answer and it worked for me, if you are on linux anyway. You have to open a term up and do "ssh-add /path/to/idrsa" and thats it. Then try to reconnect. My username is hjones so I would type "ssh-add /home/hjones/.ssh/idrsa".

Have another answer? Share your knowledge.