Creating new droplet with SSH keys didn't work

  • Posted February 8, 2015

I followed this guide to the letter:

However after creating the droplet (Step 5) I tried to log into my server but got this:

forrester@:~$ ssh root@****** Agent admitted failure to sign using the key. root@***********'s password: Permission denied, please try again

I tried my SSH key passphrase as the password but as you can see it didn’t work. Seeing as I opted into the SSH key I never got an email with a password. How can I fix this?


Soluction in terminal for error

Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).

ssh-keygen -f " ~/.ssh/known_hosts" -R

xx - ip host

This comment has been deleted

Running ssh -vv root@******** will give you more verbose error output. That might help figure out the issue here. If you created the SSH key in a non-standard location, remember to pass the path to the key: ssh -i /path/to/id_rsa root@********

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I just figured out the answer and it worked for me, if you are on linux anyway. You have to open a term up and do “ssh-add /path/to/id__rsa” and thats it. Then try to reconnect. My username is hjones so I would type “ssh-add /home/hjones/.ssh/id__rsa”.

This comment has been deleted