Question

Cron dont work in zpanel

Posted April 30, 2014 5.1k views
I have a domain with ZPanel with a cron job, Apparently has configured ok, but was never executed. If I run the php from the url is running ok. The cron log: Apr 29 21:45:01 localhost CRON[4864]: (root) CMD (/usr/bin/php -q /etc/zpanel/panel/bin/daemon.php >> /dev/null 2>&1) Apr 29 21:50:01 localhost CRON[5195]: (root) CMD (/usr/bin/php -q /etc/zpanel/panel/bin/daemon.php >> /dev/null 2>&1) Apr 29 21:55:01 localhost CRON[5241]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1) Apr 29 21:55:01 localhost CRON[5242]: (root) CMD (/usr/bin/php -q /etc/zpanel/panel/bin/daemon.php >> /dev/null 2>&1) Apr 29 22:00:01 localhost CRON[5284]: (root) CMD (/usr/bin/php -q /etc/zpanel/panel/bin/daemon.php >> /dev/null 2>&1) Apr 29 22:05:01 localhost CRON[5323]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1) Apr 29 22:05:01 localhost CRON[5324]: (root) CMD (/usr/bin/php -q /etc/zpanel/panel/bin/daemon.php >> /dev/null 2>&1)

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
7 answers
Can you post a screenshot of your cronjob's config?
[IMG]http://i61.tinypic.com/j5lbw6.jpg[/IMG]
I'd try removing the "/dev/null 2>&1" from you command so it will produce error output showing what is failing.
SSH into your droplet and try running it on the command line:


/usr/bin/php -q /etc/zpanel/panel/bin/daemon.php


this comand runs but cron job didnt start
When that command ran, did it also run the commands that you added in the panel?
Submit an Answer