zx1905cc
By:
zx1905cc

Cron Error With Lemp Stack

April 9, 2016 1.4k views
LEMP Nginx Ubuntu

Can anyone help with this?:

"/etc/cron.daily/apt:
Package 'cloud-init' has conffile prompt and needs to be upgraded manually"

This error has started to appear after updgrading some software on my server.
I am no expert and would really appreciate some input.
Thanks in advance.

1 comment
1 Answer

It looks your server is setup to use "unattended upgrades" which installs updates automatically. On Ubuntu 16.04 these are turned on by default for security related updates. This message indicates that one package, in this case cloud-init, will prompt you for input as part of its upgrade process. So it can not be done automatically. Manually running an upgrade as normal should resolve the issue:

  • sudo apt-get update
  • sudo apt-get upgrade
Have another answer? Share your knowledge.