Question

cron job running fine when logged in as root, but not as other user (Ubuntu 20.04 droplet)

Hello,

I wrote a node.js application as a root user, setup cron to launch bash scripts and everything is running perfectly fine. I used crontab -e to edit my crontab.

I decided to clone this app on an identical Ubuntu droplet, but this time logged in as a standard user, and placed my app in its own folder. I can manually run all the bash scripts and the app is running fine, except cron won’t launch them at regular intervals.

As “root”, my crontab looked like this, and worked fine:

*/5 * * * * /bin/bash /root/myscript.sh

As “lorenzo”, I tried the following:

SHELL=/bin/bash */5 * * * * /home/lorenzo/myscript.sh */5 * * * * /bin/bash /home/lorenzo/myscript.sh */5 * * * * /usr/bin/bash /home/lorenzo/myscript.sh

Cron is running, /var/log/syslog shows the entries without errors, but the scripts are not executed. I chmod +x my scripts and they are executable.

Any idea ? I could really use a hand, thank you.

Lorenzo

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @lsandiniLobster,

It seems to be your user does not have enough permissions to run the files. This can be due to permissions or ownership.

Make sure the script /home/lorenzo/myscript.sh does have both the permissions and the correct ownership to execute this file.

Regards, KFSys