My wordpress droplet works great when using the ip address http://138.68.241.165/. But when accessing it from my domain name (ruepprich.com), the font-awesome icons do not show up because they are blocked by the CORS policy.

How can I change the CORS policy?

thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

If you view the source on your homepage ruepprich.com, you can see that all the URLs are using your IP Address, not your domain name:
source of your homepage

First thing to do is change your Wordpress settings from using your IP Address to your domain.

  1. Login to Wordpress
  2. Go to Settings > General
  3. Change both to your domain name with the http part: e.g. http://ruepprich.com

HOPEFULLY that fixes your CORS issues… :)

Context: (from Wordpress)
On the Settings->General screen in a single site installation of WordPress, there are two fields named “WordPress Address (URL)” and “Site Address (URL)”. They are important settings, since they control where WordPress thinks your site is located. They control the display of the URL in the admin section of your page, as well as the front end, and are used throughout the WordPress code.

  • The “Site Address (URL)” setting is the address you want people to type in their browser to reach your WordPress blog.
  • The “WordPress Address (URL)” setting is the address where your WordPress core files reside.

Note: Both settings should include the http:// part and should not have a slash “/” at the end.

aha,
Thanks a bunch! That did the trick!

Christoph

Submit an Answer