Question

curl: (6) Could not resolve host: bash. - Upgrade from the Legacy Metrics Agent to the Current Agent

When trying to upgrade the Legacy Metrics I keep getting the error:

curl: (6) Could not resolve host: bash

I’ve already tried suggestions found here: https://www.digitalocean.com/community/questions/curl-6-could-not-resolve-host-bash-upgrade-from-the-legacy-metrics-agent-to-the-current-agent

Still no success.

Subscribe
Share

I have the same issue, when running from a droplet this fails. Outside of a droplet it is fine


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

mine solves by disabling firewall temporarily

facing same issue one of my do instance i have tried to ping showing me

ping: repos.insights.digitalocean.com: Temporary failure in name resolution

Hello,

I assume you’re following this article: https://www.digitalocean.com/docs/monitoring/how-to/upgrade-legacy-agent/

You can also make sure that you haven’t copied some additional characters in the curl command itself:

curl -sSL https://repos.insights.digitalocean.com/install.sh | sudo bash

Also another thing to add, can you try pinging the source site/domain as well, just to see if it’s not a networking issue:

ping repos.insights.digitalocean.com

Looking forward to your reply. Alex