I am trying to enter an API key for my Mailchimp plugin for my WordPress website and I get this error:
cURL error 6: Could not resolve host

Plugin: Mailchimp for Woocommerce Settings
Error: Mailchimp says: API Request Error - cURL error 6: Could not resolve host: thepouringarts.com

Is there a fix for this? Running the latest Apache, PHP, Woocommerce and WordPress versions.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hey there!

The resolvers are having issues. The resolvers are specified in the /etc/resolv.conf file and are set based on the network configuration scripts on the Droplet. You can try rebooting the Droplet once and if the issue still persists, you can try to manually specifying nameserver IP entries in the /etc/resolv.conf file to any of the following for testing. the format looks like this:

nameserver IP.AD.DR.ESS

Google public name servers:
nameserver 8.8.8.8
nameserver 8.8.4.4

OpenDNS
nameserver 208.67.222.222
nameserver 208.67.220.220

Let me know how it goes.

Regards,
Prakash Jha
Developer Support

  • Thank you for the help, but I am still having the issue :(

    Mailchimp says: API Request Error - cURL error 6: Could not resolve host: thepouringarts.com

    I used the OpenDNS nameservers in the resolv.conf file in nano and saved and rebooted the server. I just looked now and it’s back to the default config.

    This is how it looks:

    nameserver 127.0.0.53
    options edns0
    

    I’m pretty new to this so let me know if I’m doing anything incorrect. :)

    EDIT:
    I just changed the nameservers and did NOT reboot. This worked and I was able to fix the Mailchimp plugin issue.

    How can I make it so this is permanent?

    • Hey @thepouringarts

      Any changes made to /etc/resolv.conf will be erased on reboot or networking restart. So, the workaround to make permanent changes in resolv.conf:

      1. sudo apt-get install resolvconf
      2. vi /etc/resolvconf/resolv.conf.d/base

      Insert the below Name-servers :
      nameserver 8.8.8.8

      nameserver 8.8.4.4

      Save the file.

      1. resolvconf –enable-updates
      2. resolvconf -u
      3. netplan apply
      4. systemctl restart systemd-networkd

      It will correct issues on all your Droplets.

      Keep us posted if you need any further guidance on this and if there are additional questions or concerns please don’t hesitate to reply with them.

      Regards,
      Prakash Jha
      Developer Support

Submit an Answer