Hello!
I’m trying to install WHMCS on Ubuntu 20.04 (LTS) x64 running Webmin, it seems
a CURL with SSL Support is required according to the installer. I have tried many solutions online but non worked for me. Please have anyone encountered such problem? Or any solution?
Thanks!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
4 answers

Hi there,

I believe that you need to install OpenSSL in order to get that working.

If you are on an Ubuntu server, you could do that with the following command:

sudo apt install openssl

Let me know how it goes!
Regards,
Bobby

Hello @Chijioke

Are you trying to install WHMCS manually or via Webmin as an additional addon for the control panel? I will also recommend installing OpenSSL as per Bobby’s reply.

You can check the full recommended requirements:

Also, check the requirements on the WHMCS site here:

PHP Version: Latest 7.3 or 7.4 Release
PHP Memory Limit: 128MB
PHP Database Extension: PDO
PHP Extensions:

  • Curl with SSL
  • GD2 Image Library
  • JSON Support
  • XML
  • Iconv
  • MBString
  • GMP
  • OpenSSL
  • BC Math
  • Intl

MySQL Version: Latest 5.7
Ioncube Loaders: The latest 10.x Ioncube for your PHP version

As part of PCI compliance, an SSL library capable of TLS 1.2 may be required. If using OpenSSL, version 1.0.1c or newer is recommended.

https://docs.whmcs.com/System_Requirements

If you’re installing it manually follow the steps listed on this site here:

https://docs.whmcs.com/Installing_WHMCS

Hope that this helps!
Regards,
Alex

  • Thanks for reply!
    I’m running a fresh manual Installation on Ubuntu 20.04 (LTS) x64.
    I was able to install other requirements including the ioncube.
    There is an OpenSSL installed on the server I can still see it when I run “php -i | grep -i openssl” but it still says “CURL with SSL Support Unavailable”.

  • Saw this message on the php.ini file:

    [curl]
    ; A default value for the CURLOPT_CAINFO option. This is required to be an
    ; absolute path.
    ;curl.cainfo =
    
    [openssl]
    ; The location of a Certificate Authority (CA) file on the local filesystem
    ; to use when verifying the identity of SSL/TLS peers. Most users should
    ; not specify a value for this directive as PHP will attempt to use the
    ; OS-managed cert stores in its absence. If specified, this value may still
    ; be overridden on a per-stream basis via the "cafile" SSL stream context
    ; option.
    ;openssl.cafile=
    
    ; If openssl.cafile is not specified or if the CA file is not found, the
    ; directory pointed to by openssl.capath is searched for a suitable
    ; certificate. This value must be a correctly hashed certificate directory.
    ; Most users should not specify a value for this directive as PHP will
    ; attempt to use the OS-managed cert stores in its absence. If specified,
    ; this value may still be overridden on a per-stream basis via the "capath"
    ; SSL stream context option.
    ;openssl.capath=
    
  • What I get when I run: “php -i | grep -i openssl” on terminal

    SSL Version => OpenSSL/1.1.1f
    libSSH Version => libssh/0.9.3/openssl/zlib
    openssl
    OpenSSL Support => enabled
    OpenSSL Library Version => OpenSSL 1.1.1f 31 Mar 2020
    OpenSSL Header Version => OpenSSL 1.1.1J 16 Feb 2021
    OpenSSL default config => /usr/lib/ssl/openssl.cnf
    OpenSSL .cafile => no value=> no value
    OpenSSL .capath => no value=> no value
    OpenSSL Support => enabled
    

Hello there, @Chijioke

You can try running the commands from steps VI and VII and let me know how it goes!

Regards,
Alex

Hi Alex!
Thanks for all your support.
I ran from steps VI and VII, same thing!
I think where the whole problem lies is in step V, that line is where the whole configuration lies. It means if I can’t configure it with an SSL support, the whole thing is invalid. If I can get another process of running that command, I think the problems would better be solved.
Checking the cURL version with curl --version or $ curl -V still shows no https support.