Current Ubuntu Kernel doesn't match

March 26, 2016 533 views
DigitalOcean Server Optimization Ubuntu

Hi, I now keep my server updated and so am now running Ubuntu 15.10.

uname -ir: 4.2.0-34-generic x86_64

When I login the DO control panel is says my current kernel is: 14.10 x64 vmlinuz-3.16.0-41-generic

I've tried changing it to: 15.10 vmlinuz-4.2.0-34-generic

It still says the current kernel is 14.10...

I've tried rebooting, poweroff, etc but nothing gets the two things to match up.

I did have to change the repositories a while ago because I hadn't updated for such a long time that the DO files were archived so I was stuck on a really old version of Ubuntu. I therefore stopped using the DO repositories and redirected directly to Ubuntu's own servers.

Is this the reason why the kernel's aren't matching up?

Is there a way to fix this problem? Is it actually a problem? What are the potential problems (or benefits) of my setup?



1 Answer

Hey Nick,

If you're using 15.10 and see the kernel page, it means that this Droplet used to be an older version of the OS. New builds with 15.10 would have internally managed kernels. The kernel is set to whatever shows up in the uname command. The web panel has a current bug which should be patched shortly that displays the original kernel instead of the kernel currently set.

Happy coding,

Jon Schwenn
Platform Support Specialist

  • Okay, thanks for answer. Was about to redo the entire process again, thought it didn't work. Updated to 16.04 LTS and still see 14.04 when I log in.

    Any eta for the bug fix? Kinda confusing!

    • @seanmavley The kernel page of the control panel has been fixed and shows the current set kernel. I believe that an upgrade isn't fully supported from Ubuntu until 16.04.1. You should be able to set the kernel to whatever is installed on the Droplet. Please note that if you create a new 14.04 or 16.04 Droplet right now, the kernel will be fully managed internally and the kernel page of the control panel is no longer active.

      • "I believe that an upgrade isn't fully supported from Ubuntu until 16.04.1."

        So, how do I upgrade to 16.04 LTS? Can I or I can't?

        Okay, so I'm on the 16.04LTS supported kernel, just that apt-get is still stuck at 14.04 LTS, right?

Have another answer? Share your knowledge.