Custom Images URL upload not working

September 19, 2019 176 views
DigitalOcean

I have created a .RAW file from a KVM Machine that I am trying to get uploaded as a custom image.

The Size is 55GB

I have tried to have the URL Upload from my own web server, but it never completes.

I then REad that the URL upload is limited to 3GB. and that I should upload it to Spaces, and then use the SPACES URL to import it into Custom Images.

I try to do this and it shows up as Pending after about 40 minutes or so it just disappears. I have no idea how to get my .RAW file into the Custom Images, and begining to think that this feature does not function as expected.

Basically I am needing to spin up a few Droplet now from this image, and have a way to use this feature for Disaster Recovery in the future.

Any feedback on this is greatly appreciated. I have opened a Ticket (well actually 2) yesterday and today, but have had no responses.

~ron

2 Answers

Hello,

I believe that once you have the image uploaded to Spaces it should work fine. Have you tried using Cyberduck for example to upload the image to Spaces?

Here’s a step by step guide on how to do that:

https://www.digitalocean.com/docs/spaces/resources/cyberduck/

Hope that this helps!
Regards,
Bobby

The file has already been uploaded to Spaces without incident.

The issue is how to get it from spaces to be used as a custom image.

When I try to upload it using the spaces URL to the custom image location, it shows up as pending for a while then disappears.

The Size is 55GB and is uncompressed and is type RAW, so it is well under the 100GB Limitation.

~ron

Have another answer? Share your knowledge.