Question

Cyberpanel lightspeed Droplet: Rainloop - users cannot log into accounts

Installed a Cyberpanel Litespeed Droplet. Created user account. Users setup mail account with Rainloop. Users cannot log into the mail account. Admin can log into the Rainloop administration area. How to use Rainloop with Cyberpanel or how can users log into their Rainloop accounts? Now it always gives Authentication Failed.

Subscribe
Share

/etc/dovecot/dovecot-sql.conf.ext

password_query = SELECT email as user, password FROM e_users WHERE email=‘%u’; user_query = SELECT ‘5000’ as uid, ‘5000’ as gid, mail FROM e_users WHERE email=‘%u’;

I think this is the standard way of handling pwds, decryption happens elsewhere. …?

Allowing postfix as below didn’t resolve this particular problem. chmod 644 /etc/postfix/dynamicmaps.cf It may have solved another error, but not the Invalid password in passdb: crypt()

I have a similar problem. In mail.log I see: dovecot: auth-worker(19083): Error: sql(<email>,127.0.0.1,<session>): Invalid password in passdb: crypt() failed: Invalid argument

I’ve tried connecting via external clients, it also refuses the connection. I’m thinking it may be dovecot problem not rainloop itself.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It’s been a while, I just want to share a link here about how to access webmail with Cyberpanel. https://blog.cyberpanel.net/2019/03/20/how-to-access-webmail-in-cyberpanel/

I would suggest enabling error logging and then checking the error logs for more information.

Also this thread here provides some very useful information:

https://github.com/RainLoop/rainloop-webmail/issues/233

I would recommend reading it.