Question

Dart project with Dokku. Fails push to master.

Posted January 25, 2014 4.3k views
I'm trying to build Dart project with Dokku. Doing it in same way as Node.js project. But I'm getting errors when pushing git to Dokku origin. Can you please help me with that: $ git push dokku master Counting objects: 632, done. Delta compression using up to 4 threads. Compressing objects: 100% (605/605), done. Writing objects: 100% (632/632), 7.98 MiB | 74.00 KiB/s, done. Total 632 (delta 264), reused 0 (delta 0) -----> Building svpe ... Dart app detected -----> Welcome, this machine is: Linux e82c0d50ae50 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux -----> Installing Dart VM via URL http://commondatastorage.googleapis.com/dart-editor-archive-integration/latest/dartsdk-linux-64.tar.gz remote: % Total % Received % Xferd Average Speed Time Time Time Current remote: Dload Upload Total Spent Left Speed remote: 100 127 100 127 0 0 426 0 --:--:-- --:--:-- --:--:-- 494 remote: remote: gzip: stdin: not in gzip format remote: tar: Child returned status 1 remote: tar: Error is not recoverable: exiting now To dokku@95.85.57.74:svpe ! [remote rejected] master -> master (pre-receive hook declined) error: failed to push some refs to 'dokku@95.85.57.74:svpe'

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer
Apparently the copy of dartsdk-linux-64.tar.gz dokku downloaded is corrupt which is because http://commondatastorage.googleapis.com/dart-editor-archive-integration/latest/dartsdk-linux-64.tar.gz doesn't actually exist. Try updating Dokku, perhaps it was fixed.
Submit an Answer