Question

Data truncation: Data too long for column 'content' at row 1 Query

database mysql8

How to set SQL MODE fix this error?

MySQL will truncate any insert value that exceeds the specified column width. to make this without error try Switch your MySQL mode to not use STRICT.

意思大概是MySQL将截断超过指定列宽度的任何插入值。为了让这个不报错,你可以尝试切换你的MySQL模式不使用严格模式。


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

You can set the SQL mode by finding the cluster on the Databases page -> click the cluster’s name -> Settings tab - > Global SQL mode -> Edit button -> from the drop-down menu select the SQL mode you want to modify

Save to persist the change or cancel to revert.

The link provides more information on how to set global SQL mode on MySQL clusters.

https://www.digitalocean.com/docs/databases/mysql/how-to/set-sql-mode/

Hope that this helps! Regards, Anadi