I just created a database cluster with SSL connect and assigned the IP address of my server as trusted IP. When I tried to connect using the provided flag I got the unknown variable error

mysql: [ERROR] unknown variable ‘logbintrustfunctioncreators=1’.

How do I resolve this?
Thanks
Chariya

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @cpeters5,

Can you please confirm how exactly are you trying to connect, what sofware are you using, from where you are connecting to your MySQL, are you using a Managed Database?

It seems like the software you are connecting from, doesn’t recognize this option which is strange. Most probably it’s an older version.

Regards,
KDSys

  • Thanks for your response.
    The problem is solved. I tried reinstalling mysql in hte client droplets and somehow the connection was successful.

    • Hi @cpeters5,

      Thanks for clarifying, I’m glad to hear that!

      Most probably the version was too low so reinstalling it, you installed a newer one which supported this option,

Submit an Answer