me633450
By:
me633450

Databases work on Ubuntu 14.04 image if dokku is installed manually, but not if using the Dokku image.

May 16, 2014 1.9k views
Can this be looked into. When creating a new droplet from the Dokku image, I could not get database and app to talk to each other, it was "connection refused" every time. I tried postgres, mysql and mariadb in php and python (django) apps. Using the same code (pushed from the same repo) on a droplet i created as the bare ubuntu 14.04 and installed Dokku on myself, with the same setup on teh database (same plugins and setting), same envirnonment vars setup, everything works. The Ubuntu Dokku image should probably just be Ubuntu with the dokku bootstrap script ran twice on it (running it once results in a partial install due to a bug in apt-get)
1 Answer
I got past this by updating the deploy step with the instructions here: https://github.com/progrium/dokku#upgrading

and then pushing again, but it would be great if it worked out of the box.
Have another answer? Share your knowledge.