Question

Debian machine with "jessie-backports" no longer have release file

Today I get this message when trying to run apt update on my Debian:

Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://mirrors.digitalocean.com/debian stretch InRelease
Hit:3 http://mirrors.digitalocean.com/debian stretch-updates InRelease
Hit:4 http://mirrors.digitalocean.com/debian stretch Release                                            
Ign:5 http://ftp.debian.org/debian jessie-backports InRelease                                           
Err:6 http://ftp.debian.org/debian jessie-backports Release                         
  404  Not Found [IP: 130.89.148.12 80]
Get:7 http://deb.goaccess.io stretch InRelease [2,520 B]                     
Get:8 https://packages.sury.org/php stretch InRelease [6,760 B]              
Hit:9 https://download.docker.com/linux/debian stretch InRelease
Get:10 https://deb.nodesource.com/node_6.x stretch InRelease [4,635 B]
Hit:11 https://repos.sonar.digitalocean.com/apt main InRelease
Err:8 https://packages.sury.org/php stretch InRelease      
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743
Reading package lists... Done 
E: The repository 'http://ftp.debian.org/debian jessie-backports Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packages.sury.org/php stretch InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B188E2B695BD4743

Any help will be much appreciated :)

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, I got a similar problem, but not for the backports, but for this four:

W: Failed to fetch http://mirrors.digitalocean.com/debian/dists/jessie-updates/main/source/Sources  404  Not Found [IP: 104.24.116.209 80]

W: Failed to fetch http://mirrors.digitalocean.com/debian/dists/jessie-updates/main/binary-amd64/Packages  404  Not Found [IP: 104.24.116.209 80]

Err http://mirrors.digitalocean.com jessie-updates/main Sources
  404  Not Found [IP: 104.24.116.209 80]

Err http://mirrors.digitalocean.com jessie-updates/main amd64 Packages
  404  Not Found [IP: 104.24.116.209 80]

Is there some help on that one?

@jarland I see. Thank you for your answer.

What would be the best thing to do from now for existing Droplets? Shall we totally delete them and move data to a new one? Any upgrade path your team is aware of?

Hi @jarland and thank you for your answer.

I don’t think that’s my responsability to update source list because, as you can see, Debian-based Droplets rely on Digital Ocean mirrors:

# See http://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.html
deb http://mirrors.digitalocean.com/debian stretch main contrib non-free
deb-src http://mirrors.digitalocean.com/debian stretch main contrib non-free

# Major bug fix updates produced after the final release of the distribution.
deb http://security.debian.org stretch/updates main contrib non-free
deb-src http://security.debian.org stretch/updates main contrib non-free
deb http://mirrors.digitalocean.com/debian stretch-updates main contrib non-free
deb-src http://mirrors.digitalocean.com/debian stretch-updates main contrib non-free

Is Digital Ocean team working on something to fix this situation?

Greetings!

The Debian team has disabled the Jessie backports repository. I do not believe that they intend to update it further, but I’m told that you can continue to use the archive of the repository by changing “ftp.debian.org” to “archive.debian.org” in your apt source list.

Jarland