Question

Default Root password for MySql wont work

  • Posted on January 13, 2015
  • MaricruzAsked by Maricruz

Hi, I just created a new droplet and used the “LEMP on Ubuntu 14.04” application to set it all up and have LEMP installed automatically. I am trying to run “sudo mysql_secure_installation” for obvious reasons and it is asking me for the root password. I tried entering the password that is given on startup:

The details of your PHP installation can be seen at http://xxx.xxx.xxx.xxx/info.php  
Your MySQL root user's password is XXXXXXXXXX  You are encouraged to run 
mysql_secure_installation to ready your server for production.  

But it will not work! The error msg is: ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

Any help would be appreciated.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi,

The below tutorial can assist you with setting up LEMP on ubuntu 14:

https://www.digitalocean.com/community/tutorials/how-to-install-linux-nginx-mysql-php-lemp-stack-on-ubuntu-14-04

You can also feel free to check digitalocean LEMP from the marketplace.

https://marketplace.digitalocean.com/apps/lemp

Regards, Rajkishore

This comment has been deleted