Question

Defaultsite page is showing After Hosting

Hi All,

I have hosting in digital ocean and domain in 1&1.com. Yesterday, I tried to setup server, created my droplet, pointed Digitalocean DNS under my domain in 1&1.com & installed wordpress application.

Near to 1 day it took for pointing. When I accessed my domain using my friends laptop the website was perfect with wordpres application it showed. And also, I check my website on mobile device it is opening perfectly. But when I accessed my domain using my IP which I used to setup all configuration it showed default page like mydomain.com/defaultsite

Why does it happen? Is there any solution for this?

Thanks

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

@prabhu82 - Look for the server block in files /etc/nginx/sites-enabled defined as the default_server and display a redacted version here. If you don’t have a default_server defined, then pick the server block you want to make the default and define it. For example, if you have

server {
 # stuff here
 listen 80;
 # redirect or rewrite here
}

change it to

server {
 # stuff here
 listen 80 default_server;
 # redirect or rewrite here
}

The issue has been solved. I didn’t do anything it got resolved automatically. Still, wondering what might be the reason for this.

nginx & Ubuntu 14.04.4 x64