Delegating a Subdomain + NSD setup


First time with DNS, but I need to delegate a subdomain to my own DNS. Is it possible in DO interface ?

I’ll enumerate my questions to make it easier to reply :)

  1. Is this right what i’m doing on screenshots?

First one is DNS records of (not real) that delegated to as usual, it works fine.

Second is what im trying. I add a domain “” and add NS record to it.

So it works like that?

  1. In 2nd screenshot i put two “glue” A records - it’s just i tried to make it work. I’m not sure is they need there or not? Because already have A record for in the parent domain interface (1st screenshot).

  2. I’m also trying to realise, can i use for my subdomain only one master-only NS server without slave.

Or if not, I’m thinking can i use my as master, and as slave. And also i have seen living examples where ns1 and ns2 have the same IP…

(Reliability issues i do not care.)

(But the reliability of the main domain worries me, and that’s why i do not want to setup my own DNS for the main domain itself, and why trying to setup a subdomain for my purposes)

  1. Server part. I use NSD server


    name: ""
    zonefile: ""
    ;notify: NOKEY
    ;provide-xfr: NOKEY

$TTL 1800
@       IN      SOA (
                        2015080800              ; serial number
                        3600                    ; refresh
                        900                     ; retry
                        180000                  ; expire
                        1800                    ; ttl

        IN      NS
        ;IN      NS

ns1     IN      A

But what I see it still not working, not resolving (after hours), and SOA record still in

$ dig any +multiline

; <<>> DiG 9.10.2-P2 <<>> any +multiline
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31654
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;                IN ANY

;; ANSWER SECTION:         1456 IN NS         1456 IN SOA (
                                1439102949 ; serial
                                10800      ; refresh (3 hours)
                                3600       ; retry (1 hour)
                                604800     ; expire (1 week)
                                1800       ; minimum (30 minutes)

;; Query time: 10 msec
;; MSG SIZE  rcvd: 128

I use debug-mode: yes and verbosity: 2 in nsd.conf. But only message i saw in /var/log/nsd.log is :

	error: xfrd: zone max notify send count reached, unreachable

after I tried to add as slave (commented line in nsd.conf and Also tried to add reverse zones, but not helps, and i’m not sure whether they are necessary to me.

Would be very grateful if someone answers to at least some of my questions. And I’m going to read the DNS AND BIND book … :))

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This question was answered by @jesin:

DigitalOcean doesn’t support DNS delegation yet and adding a subdomain to the DO panel will only delegate it to DO itself.

Use CloudFlare for DNS (you can turn off their additional features) and delegate the subdomain to your NSD server. DO’s nameserver run on CloudFlare so you won’t notice any performance difference.

View the original comment