Question

deployment error uploading app with strapi/nodejs

Posted October 27, 2021 121 views
Node.jsDeploymentStrapi

I am uploading strapi/node as app on DO but i am getting deployment error and deplyment logs are use less no error is recorded there, i tried to create ticket on support but description field is not working and it is disabled too

1 comment
  • [2021-10-27 13:27:57] FetchError: request to https://sub-backend-2-fzf6e.ondigitalocean.app/admin failed, reason: getaddrinfo ENOTFOUND sub-backend-2-fzf6e.ondigitalocean.app
    [2021-10-27 13:27:57] at ClientRequest.<anonymous> (/workspace/nodemodules/node-fetch/lib/index.js:1461:11)
    [2021-10-27 13:27:57] at ClientRequest.emit (events.js:400:28)
    [2021-10-27 13:27:57] at TLSSocket.socketErrorListener (
    httpclient.js:475:9)
    [2021-10-27 13:27:57] at TLSSocket.emit (events.js:400:28)
    [2021-10-27 13:27:57] at emitErrorNT (internal/streams/destroy.js:106:8)
    [2021-10-27 13:27:57] at emitErrorCloseNT (internal/streams/destroy.js:74:3)
    [2021-10-27 13:27:57] at processTicksAndRejections (internal/process/task
    queues.js:82:21) {
    [2021-10-27 13:27:57] type: ‘system’,
    [2021-10-27 13:27:57] errno: 'ENOTFOUND’,
    [2021-10-27 13:27:57] code: 'ENOTFOUND’
    [2021-10-27 13:27:57] }

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hey there!

I’m sorry to hear you haven’t been able to open a ticket. You may want to try using another browser without any extensions enabled to see if the description field issue is addressed.

As for the error you are seeing it looks like you are trying to access the app’s URL but are hitting an issue resolving the name. If you are making a call to that using options you will need to make sure you aren’t specifying the http:// in the host field of the options section. Since that is the URL of your app you do need to use SSL as all apps are only accessible on that protocol. That being the case you would need to use the https module in your code as well.

Hope it helps!
Nate