Question

Deployment failed

I tried to deploy https://github.com/MikeMeyersLT/sunnyday. Build succed but deployment failed and I can’t find what the problem is. All I can see is that Component issues. Please let me know what the problem is.


Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I don’t know the answer to your specific problem, but I had the same problem with limited debug output.

My specific issue was an architecture build issue, as I’ve got an M2 mac. My solution was to build from a linux operating system on a digital ocean droplet and push to the application’s image registry with the x86_64 image.

In my opinion, which is what I’m now doing, booting up a digital ocean droplet and hosting my application on there with a docker container run command is a more troubleshootable approach. No doubt what Digital Ocean does with the applications is useful and secure, but it comes at a cost of not being able to troubleshoot issues, and let’s be honest: Issues happen a lot.

You no longer have the feature of Zero Downtime Deployments, and Automatic rollbacks on failed deployments, but you do get much better analysis over your application and can actually access the application while it’s running for some production logs.

Our team does this for every application we run for Digital Ocean so we don’t have to guess anything!

Bobby Iliev
Site Moderator
Site Moderator badge
June 19, 2023

Hi there,

I just forked your project and tried deploying it and it seems to work out of the box as long as you’ve defined your OpenAI API key as an OPENAI_API_KEY env variable.

A few things that you could also look into in case you’ve made any changes to the default deployment configuration are:

  • Make sure that your HTTP Port is set to 8080 as this is what’s defined in your app.py file
  • Make sure that your Health Check is set to TCP
  • Make sure that your Run Command is set to python app.py as this is what your app file name is

With those settings in place, which are the default ones, your app runs as expected.

Hope that this helps!

Best,

Bobby

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel