Question

Did these updates cause fingerprint change and SSH warning?

I logged in and did a few updates around noon, and when I rebooted and tried to log back in, my WinSCP program screamed “WARNING - POTENTIAL SECURITY BREACH!” I cancelled and tried again every half hour until I finally decided to just override it and login. I looked at the logs and think things seem normal.

The server is a few years old and I have always had password authentication shut off. The keys are 2048 length with password protection them. I am the only person with access to this server. It did NOT have fail2ban installed.

Here is the info on what I updated that may be to blame for the warning.

Start-Date: 2018-09-17  12:22:14
Commandline: apt-get upgrade
Upgrade: linux-virtual-lts-xenial:amd64 (4.4.0.134.140, 4.4.0.135.141), cloud-init:amd64 (18.2-4-g05926e48-0ubuntu1~16.04.2, 18.3-9-g2e62cb8a-0ubuntu1~16.04.2), uuid-runtime:amd64 (2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), libfdisk1:amd64 (2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), linux-libc-dev:amd64 (4.4.0-134.160, 4.4.0-135.161), libmount1:amd64 (2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), snapd:amd64 (2.32.9, 2.34.2), squashfs-tools:amd64 (1:4.3-3ubuntu2.16.04.1, 1:4.3-3ubuntu2.16.04.3), certbot:amd64 (0.25.0-1+ubuntu16.04.1+certbot+1, 0.26.1-1+ubuntu16.04.1+certbot+2), open-iscsi:amd64 (2.0.873+git0.3b4b4500-14ubuntu3.4, 2.0.873+git0.3b4b4500-14ubuntu3.5), python-apt-common:amd64 (1.1.0~beta1ubuntu0.16.04.1, 1.1.0~beta1ubuntu0.16.04.2), udev:amd64 (229-4ubuntu21.2, 229-4ubuntu21.4), initramfs-tools-bin:amd64 (0.122ubuntu8.11, 0.122ubuntu8.12), linux-headers-virtual-lts-xenial:amd64 (4.4.0.134.140, 4.4.0.135.141), libudev1:amd64 (229-4ubuntu21.2, 229-4ubuntu21.4), systemd-sysv:amd64 (229-4ubuntu21.2, 229-4ubuntu21.4), python3-acme:amd64 (0.25.1-1+ubuntu16.04.1+certbot+1, 0.26.0-1+ubuntu16.04.1+certbot+1), ubuntu-core-launcher:amd64 (2.32.9, 2.34.2), shared-mime-info:amd64 (1.5-2ubuntu0.1, 1.5-2ubuntu0.2), libsmartcols1:amd64 (2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), libglib2.0-data:amd64 (2.48.2-0ubuntu1, 2.48.2-0ubuntu4), python3-certbot:amd64 (0.25.0-1+ubuntu16.04.1+certbot+1, 0.26.1-1+ubuntu16.04.1+certbot+2), libjs-sphinxdoc:amd64 (1.3.6-2ubuntu1.1, 1.3.6-2ubuntu1.2), libglib2.0-0:amd64 (2.48.2-0ubuntu1, 2.48.2-0ubuntu4), initramfs-tools-core:amd64 (0.122ubuntu8.11, 0.122ubuntu8.12), initramfs-tools:amd64 (0.122ubuntu8.11, 0.122ubuntu8.12), python3-apt:amd64 (1.1.0~beta1ubuntu0.16.04.1, 1.1.0~beta1ubuntu0.16.04.2), libslang2:amd64 (2.3.0-2ubuntu1, 2.3.0-2ubuntu1.1)
End-Date: 2018-09-17  12:22:46

Start-Date: 2018-09-17  12:23:51
Commandline: apt autoremove
Remove: python3-ndg-httpsclient:amd64 (0.4.2-1+certbot~xenial+1), liblockfile-bin:amd64 (1.09-6ubuntu1), sendmail-cf:amd64 (8.15.2-3), sendmail-base:amd64 (8.15.2-3), liblockfile1:amd64 (1.09-6ubuntu1)
End-Date: 2018-09-17  12:23:52


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hey friend!

There are greater minds than my own on this, but I see a cloud-init upgrade there, and I have known cloud-init to re-generate host keys in some cases in the past. Whether due to our implementation, a bug, or intended function is a bit outside of my personal understanding of how cloud-init functions (and I would delegate such to someone who may know more about it). As for me at least, seeing the correlation there doesn’t strike me as the strangest thing I’ve seen. If that counts :)

Jarland

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks Jarland. I would love some additional input from anyone with knowledge. But that does comfort me a bit, so I will mark it as an accepted answer. Thanks again.