Digital Ocean: Kernel Panic After CPU & RAM Resize

Hi there, Digital Ocean Community, I have a digital ocean droplet that was on $56 per month with premium intel CPU & 8 Gigs of Ram. We had purchased this server two years ago. Now due to some reasons, we had to upgrade the ram of server.

After initial research, we upgraded the RAM & CPU (Only) option and didn’t go with anything besides this.

For this, I booted in my droplet and wrote the command:

shutdown -h now

After turning off droplet safely, I upgraded the ram & cpu of server which took only 1 minute.

After that I rebooted into server and from that time I am getting

“end Kernel panic — not syncing : VFS :Unable to mount root fs on unknown—block(0,0)”

I tried talking with support team, and they sent me some commands + Urls to websites to follow to resolve the issue.

But nothing has been helping me so far. What’s more troublesome is that I cannot create another droplet, because there’s a lot of data on existing droplet.

Here’s what I have followed so far:

mount /dev/vda1 /mnt
mount --bind /dev /mnt/dev
mount --bind /dev/pts /mnt/dev/pts
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys
chroot /mnt/
grub-install /dev/vda1
grub-install --recheck /dev/vda1

Can anyone please help me out on this issue?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
January 16, 2024


When I’ve had similar problems, I’ve tried some of the following:

  1. Check Boot Loader Configuration:

    • After chroot /mnt/, ensure the GRUB configuration is correct. Sometimes, the GRUB config might not correctly identify the root file system.
    • You can edit the GRUB configuration file (/etc/default/grub) and then run update-grub again.
  2. Reinstall the Kernel:

    • While in the chroot environment, you might want to try reinstalling the kernel. This can sometimes resolve issues with kernel panic. Use apt-get install --reinstall linux-image-$(uname -r) to reinstall the current kernel.
  3. Check File System Consistency:

    • Before mounting the filesystems and chrooting, run a file system check on your root partition (/dev/vda1). Use fsck /dev/vda1 to check and repair the file system.
  4. Review fstab File:

    • In the chroot environment, check the /etc/fstab file to ensure that the entries there correctly match your disk partitions and file systems.
  5. Recheck GRUB Installation:

    • The command grub-install /dev/vda1 is typically not recommended as it installs GRUB on the partition rather than the MBR (Master Boot Record). You should use grub-install /dev/vda instead. This installs GRUB in the MBR of your disk, which is usually required to boot properly.

If it doesn’t help, please provide me with your Ticket Reference so that I can try and get more support from DigitalOcean for you.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel