Question

Digital Ocean Monitoring API always returns empty result

So I am trying to add droplet monitoring to my app and want to use CPU monitoring data from digital ocean API.

I’m getting this response for every single droplet. I’ve also tried putting same timestamps DO puts in internal monitoring requests for my droplets, still no success.

{"status":"success","data":{"resultType":"matrix","result":[]}}

Could anyone help with this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

I’ve just tested this and it looks like that in order for you to be able to use the monitoring API, you need to have the DigitalOcean monitoring agent installed on your server as per the instructions here:

https://docs.digitalocean.com/products/monitoring/how-to/install-agent/

Once installed the result array should populate with data. Hope that this helps! Best, Bobby