Question

digitalocean account created but free credits not showing

I have recently subscribed as a new user, I should get $100 credits as a new sign up, but I didn’t get any free credits.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello all,

This is just an update on an older topic in case someone stumbles upon it:

Usually, in order to get your Free Trial/Github Studen Pack credit, you need to add a valid payment method, that’s all. It should appear in your Control Panel in the Billing Section. If you’ve added a valid payment method (Paypal, a payment card, etc.) you should get the credit. Having said that, if you’ve not added the Payment method the best possible way forward would be to contact DigitalOcean’s Support.

They should be able to help you out with your account issue. You should be able to reach them here:

https://www.digitalocean.com/support/

If you are unsure if you have received the free credits, you’ll need to go to your Control Panel --> Billing.

Hope that helps! - KFSys.

Hi @MattIPv4,

what was your eta for attempting a ticket, you team taking too much time to attend the tickets, please provide your SLA matrix for attending, we will wait until your team responds.

Regards, Vinod

Hello @MattIPv4,

That is not an amazing support team, I have raised ticked 6hrs back, but till now no one has responded since I expected some info from this community,

anyway thanks @MattIPv4 for the quick response. i will wait till “our amazing support team” responds.