Question

Digitalocean Apps error deploying NPM when caret (^) before version number.

Posted April 18, 2021 192 views
Node.jsDigitalOcean App Platform

I had the following code in my package.json file.

"engines": {
    "node": ">=10.16.0 <=14.x.x",
    "npm": "^6.0.0"
  }

and I got the following error:

unable to invoke layer creator
parsing package npm version range ^6.0.0: Could not parse Range "^6.0.0": Could not parse comparator "^" in "^6.0.0"
ERROR: failed to build: exit status 1

When I removed the caret (^), from before 6.0.0, the deployment worked just fine. Using the caret (^) is a common thing in package.json, but for some reason it is not working here. What’s up with that?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi there,

What I could suggest is trying with the following syntax instead:

    "npm": ">=6.0.0"

Let me know how it goes!
Regards,
Bobby