Question

DigitalOcean mirrors failing?

  • Posted February 9, 2014

Tried to do apt-get on my ubuntu droplet and getting a ton of 404’s similar to this:

Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/main/o/openssl/libss l-dev_1.0.1-4ubuntu5.10_amd64.deb 404 Not Found [IP: 95.85.0.50 80]

Subscribe
Share

Same issue here. And cannot solve it =/

Already tried https://www.digitalocean.com/community/questions/ubuntu-14-04-apt-get-update-404-not-found-issue with kakeiso97’ comment. But no change.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I’m facing the same problem in Ubuntu 14.10. apt-get update fails with digital ocean mirrors if I move to default ubuntu mirrors works.

Hello! <br> <br>Please execute this command to update your package lists, then retry your installation: <br> <br>apt-get update <br> <br>Regards, <br>Will <br>

Just ran into this issue on my end while using the plumberDeploy R package.

Getting the error: Failed to fetch http://mirrors.digitalocean.com/ubuntu/pool/universe/a/apt/apt-transport-https_2.0.5_all.deb 404 Not Found

I also had problems with this, when doing a do-release-upgrade on a 14.04 droplet Here’s what fixed it for me:

  • replaced mirrors.digitalocean.com with archive.ubuntu.com
  • commented / removed any extra sources, especially the ones with https
  • had to manually downgrade my apt version from 1.0.1ubuntu2.13 to 1.0.1ubuntu2

replacing mirrors.digitalocean.com with old-releases.ubuntu.com resolved the issues for me so I could install the upgrades needed for a dist-upgrade.

I opened a ticket with Digital Ocean and this was the fix for me:

Are you by chance using Ubuntu 14.04 on the Droplet having issues?

The reason for that particular error has to do with Ubuntu 14.04 that is now end of life (EOL). The issue is known by Ubuntu, but is unlikely to get major attention due to it being EOL.

In order to workaround the issue, you will need to update “/etc/apt/sources.list.d/digitalocean-agent.list” manually to use http instead of https as follows:

sed -i ‘s/https/http/g’ /etc/apt/sources.list.d/digitalocean-agent.list sudo apt-get update sudo apt-get install do-agent

#Change /etc/apt/sources.list nano etc/apt/sources.list

Replace “mirrors.digitalocean.com” with “archive.ubuntu.com

FWIW, my droplet is running Ubuntu 13.10 and apt-get seems to work fine.