Question

DigitalOcean's IP space blocked by Yahoo. Anyone know a good mail provider to send email (Not spam)? ( Cheap but reliable )

  • Posted January 25, 2015

Hi Guys,

My systems send emails ( Not spam ) but emails to clients etc. It can be a few hundred a day at the moment. Mostly chat logs etc from my support system.

However, The Digital Ocean IP I have ( and possibly the subnet ) is blocked by Yahoo :(

Annoyingly I have an email on yahoo so I dont get mails from the servers either.

Anyone know a good supplier I can relay through?

I can only guess the people before me must of been naughty with their IP’s and have clearly screwed me slightly as now my new server address is blocked.

Thanks G

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

any suggestions for a ispconfig3 sstem with postfix and ubuntu? I did change 3 times the DO ip fort his and yahoo blocks again.

This happened to me, and I’ve already had set SPF/TXT record. The problem was that PTR records don’t match. To set PTR record just change your Droplet’s name to your server’s domain name. DigitalOcean will automatically set the value for the PTR record. That worked! You don’t have to use any other mail service (if you just want to send mail).

Gmail, Yahoo and many others uses your PTR record to double check that the sender’s servername (in this case, your server) matches the server’s IP.

Thanks EpicCDN

I have decided to use mandrill and so far VERY pleased!

I managed to get php to also use mandrill by changing how sendmail works by installing msmtp.

Guide for others | centos 7

yum install epel-release
yum install msmtp

Created a new config file for it in /etc/msmtprc With the following info in the file:

account Test
tls on
tls_starttls on
tls_certcheck off
auth on
host smtp.mandrillapp.com
user MYUSERNAME
from noreply@mydomain.com
password MYPASSWORD
logfile /var/log/msmtp/msmtp.log

Then I modified the php.ini file. ( commenting out the old line for sendmail )

;sendmail_path = /usr/sbin/sendmail -t -i
sendmail_path = "/usr/bin/msmtp -C /etc/msmtprc -a Test -t -i"

Restarted apache and POW it works.

Don’t even waste time using MTA on your servers, use Mandrill (mandrillapp.com) or mailchip (mailchimp.com) depending on your needs, If you know about how to configure your MTA you can set it to use mandrill as smart relay, but that is a little more advance, also you can use php to send using mandrill’s app.

You get up to 12k email at month for free, so don’t worry about investing any money to replace MTA.

Remember to hearth ;-)

@vps Yeah, I did think about doing this. I guess this will be my last option.

Thanks for the feedback. i suspect this is what Ill do when the platform is a little less busy.

-G

Maybe your mail server is miss configured, so it’ll be blocked by Yahoo. In most cases it’s because the headers, or missing SPF records etc. etc.

If you would like, we could analyse your configurations.

I know its blacklisted. Yahoo’s servers come back saying so when my server tries to send. ( Both of my servers are )

Never had the problem on other hosts and these have been denied mail access from the very start, so whoever had the IP’s before were clearly spamming.

I’ve requested that the IP’s be unblocked by as normal yahoo just ignore the requests.

:(

Check if the IP in question is on a blacklist. I can verify that Yahoo is not blocking DigitalOcean on the whole.