Disable Kernel Auto Updates

September 9, 2016 136 views
LAMP Stack CentOS

Hi all,

Yesterday one of our CENTOS server started behaving weird. After restarting the server it lost all the networking functionality.

After reading I noticed the server in fact had too kernels installed:

64 ( with the timestamp of when the problems began )

I tried everything but I wasn't able to get back the network services ( NetworkManager not regular network), so I had to create another Droplet and start the restore process.

Is there any way to disable the auto update feature so this would not happened again?



2 Answers

Since the question you linked to was posted we have updated some thing. If you created a new droplet recently this is no longer an issue. Our OS images now completely use self-managed kernels or boot to a grub loader that uses the default kernel set in your droplet which means that kernel updates will work just as expected and will not require any changes on your part.

The problem I had was with a two months old droplet. Do you mean that with the new self-managed kernel, the problem will not happened again?

Have another answer? Share your knowledge.