Question

Disable password, SSH works (Ubuntu)

  • Posted December 5, 2013

Hi, I have created a new user (non-root) with SSH key. I can login using SSH key though Pageant. But when i remove my key from Pageant, I am also able to login through my password.

I have done the following in /etc/ssh/sshd_config: PasswordAuthentication no UsePAM no

Sudo reload ssh

What other settings am i missing out to prevent successful password logins?! Thank you!

Subscribe
Share

I was having the same issue. I did 2 things that which solved my problem (not sure which one did the trick)

  • Restarted my droplet:

sudo reboot

  • On my client machine, removed my “known_hosts” entry for my server:

ssh-keygen -f /home/<user>/.ssh/known_hosts -R ip.ip.ip.ip


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

ChallengeResponseAuthentication no
PasswordAuthentication no

sudo service ssh restart

I recommend reverting UsePAM to its original value and restarting ssh: <br><pre>sudo service ssh restart</pre> <br> <br>Then try logging in with your password.

set ChallengeResponseAuthentication no in /etc/ssh/sshd_config

Hi Kamal, Sorry seems like I wasn’t clear earlier. I am able to login using my password & SSH key. but for higher security, i would like to disable my password and only use SSH key to connect. I’ve set ‘PasswordAuthentication no’ and ‘UsePAM no’ but with these settings, i can still login with my password. Any idea why? thanks :))