Disable upstream response buffering nginx

Posted October 17, 2020 644 views

Nginx keeps logging below message on my error log

[warn] 16387#16387: *1117 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/1/32/0000000321 while reading upstream, client:, server:

this fills up my log files , i want to disable buffering completely ,

i’ve tried turning proxybuffering `proxybuffering off;` but the logs keeps showing that nginx/fastcgi is buffering responses

How do i turn off buffering all together ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Bumped into your question while figuring out my case, not sure if this helps you but there is a separate setting to disable fastcgi buffering:

fastcgi_buffering off;

See also