Question

Django - Gunicorn bind problem - Import error no module named django.conf

I am going through the How To Install and Configure Django with Postgres, Nginx, and Gunicorn tutorial and I got stuck in the ninth step.

When I try to execute the command gunicorn_django bind… I get an error that says Import error: no module named django.conf that is coming from the …/gunicorn/app/django_wsgi.py.

The virtualenv is activated, I am logged in as root and I also tried to run that command with sudo. Still no success…

Any ideas?

Subscribe
Share

Following this tutorial… you should be able to bind from within the virtual env. https://www.digitalocean.com/community/tutorials/how-to-set-up-django-with-postgres-nginx-and-gunicorn-on-ubuntu-18-04

cd ~/myprojectdir gunicorn --bind 0.0.0.0:8000 myproject.wsgi

That works for me if I am in the venv… however, it doesn’t work automatically, because the config for exec start. ExecStart=~project/projenv/bin/gunicorn --bind unix:/run/gunicorn.sock myApp.wsgi:application

The issue is that the bind is missing the OS Path try: gunicorn --env DJANGO_SETTINGS_MODULE=myproject.settings myproject.wsgi

you can also try to follow this tutorial. https://simpleisbetterthancomplex.com/tutorial/2016/10/14/how-to-deploy-to-digital-ocean.html


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I have the same issue. Some answer?