Question

Django Problem after Droplet snapshot and Power On/Off

Posted June 29, 2021 71 views
NginxDjangoDigitalOcean Droplets

I had my Django app running successfully in a droplet. I was accessing site through IP provided by DO. I had to deploy the same project for another client. So I powered off the droplet, created snapshot and created another droplet from snapshot image. Everything looked quite fine but I started to find a weird issue. I have a form, when i submit a form, it gets submitted successfully. I can also confirm in in django admin. Submitted form values are all good. But i render those form value in pdf (I am using Xhtml2pdf). Now when i access that pdf, it gives me previous values. It seems like it’s caching something (but i haven’t cached anything). Initially i thought this problem is only in this new droplet but i found that same thing is happening in other droplet which was running fine until now.

Things I tried

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @getpushpan,

Without going through the code itself I can’t suggest anything at the moment, maybe someone else can provide more useful information on that.

Having said that, what I would do in this situation is try and compare both setups and applications. This might prove very helpful. Going through the logs located in /var/log might help you as well