DNS A Record always changes to my email address

Trying to add a domain. So changed the DNS info to point to ns2 / ns3

Digital Ocean control panel add domain / the assigned ip address. If I go to the ip address I see the welcome to nGinx so thats fine. But for the last 12 days the domain has not worked yet. I never had to set any DNS records on other VPS i simply pointed the registar DNS to and within an hour up and running.

Any help in simply english would be great. The docs on A AAAA records are to complicated. Since I never had to do it before on other hosts why am I forced to do it here. Am I supposed to? Optional. Not sure where I am going wrong but my A record is always the email address used to log into DOcean control panel. Delete add A record. Type domain and the ip address , save. Returns to DNS with the email there.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

What is your domain name? Have you tried editing the A record using a different browser? It’s possible that there’s an addon/plugin/extension that might be auto-filling the A field with your email address.