DNS cache problem

I have several droplets and with curl i can connect to a specific url. But on 1 droplet its not possible i get this error:

curl -vv #example_url

  • Rebuilt URL to: #example_url
  • Hostname was NOT found in DNS cache
  • Trying #ipadress…
  • connect to #ipadress port 8088 failed: Connection timed out
  • Failed to connect to #ipadress port 8088: Connection timed out
  • Closing connection 0 curl: (7) Failed to connect to #ipadress 8088: Connection timed out

How can i clear/fix this DNS cache problem? Firewall is disabled.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @matthijsd7af445

If the command returns no output then the service is not running at the moment. Could you please try to restart the service which is also running fine on the other droplets and try again? I assume you have a web server like Tomcat running on this port.

Let me know how it goes.

Regards, Alex

I tried a reboot the droplet.

For your knowledge: i do the curl command on the droplet. I have also 3 other droplets and there it works fine. Only on this droplet i get this. It’s the oldest one with ubuntu 14 on it.

netstat -plunta | grep 8088 gives no output.

Hello, @matthijsd7af445

If you’re not able to connect to the IP address as well using curl this might not be a DNS issue. Have you tried rebooting the droplet? Also have you tried to connect using alternative network/device as well? Can you check if currently port 8088 is open and the rescpetive service is listening on it? You can do that by executing this command from the droplet.

netstat -plunta | grep 8088

Let me know how it goes

Regards, Alex