Question

DNS not working

Can anyone help me with my server? My DNS doesn’t seem to be working. I continuously get this error “www.45.55.201.63’s server DNS address could not be found.”

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

There is period called DNS Propagation. It’s the period needed to wait after changing nameservers. As you are using Namecheap (correct me if I’m wrong), it could take 24-72 hours. Namecheap explained this very well for their service and this is something you can read - DNS Propagation – Explained.

I don’t think it’s anymore problem. Before half hour (about 21pm CET) whois would return following nameservers:

WHOIS output for nameservers
Name Server: DNS1.NAMECHEAPHOSTING.COM Name Server: DNS2.NAMECHEAPHOSTING.COM

Now it does return DigitalOcean nameservers but I’m still not able to ping your site:

WHOIS output for nameservers
Name Server: NS1.DIGITALOCEAN.COM Name Server: NS2.DIGITALOCEAN.COM Name Server: NS3.DIGITALOCEAN.COM

If it still doesn’t work for you - verify you added domain correctly. When you go to Control Panel -> Networking, you must domain added as it is. It must be added as csgodash.win not for example www.csgodash.win or something other.

You must have 4 records under that domain - 3 NS records and 1 A record pointing to Droplet IP. To check if everything is correct you can also look at zone file, in your case it should look in lines of this:

$ORIGIN csgodash.win.
$TTL 1800
csgodash.win. IN SOA ns1.digitalocean.com. hostmaster.csgodash.win. 1477773333 10800 3600 604800 1800
csgodash.win. 1800 IN NS ns1.digitalocean.com.
csgodash.win. 1800 IN NS ns2.digitalocean.com.
csgodash.win. 1800 IN NS ns3.digitalocean.com.
csgodash.win. 1800 IN A droplet-ip

By image you linked - it looks OK. But make sure you added domain correctly. :)

This comment has been deleted

This comment has been deleted

This comment has been deleted

how can someone help you if you dont give your domain name?