Hello

Tonight I started messing around with a new server, and switched my main domain name over to the new IP and everything seemed to work fine. Then, the main domain name stopped working (Chrome says ERRNAMENOT_RESOLVED). Subdomains still worked, and my webmin still worked (on port 10000) but I can’t get to anything on the main domain. Tired of fussing with it, I delete that record in the Digital Ocean control panel and create a new entry for the original server, which hasn’t been touched. Now it too doesn’t work on the main domain name. Again, my control panel (vestaCP) and subdomains work, but the main site produces a DNS error. Any idea what might be causing this?

Domain name: blueleafweb.com
Test server IP: 104.236.13.252
Original IP: 104.236.231.203

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

That did it - wow. Thanks! What a weird thing.

It appears that blueleafweb.com is resolving but the web server at blueleafweb.com is redirecting requests to www.blueleafweb.com. There does not appear to be an A or CNAME record created for www.blueleafweb.com.

Assuming you are using the default settings in the DigitalOcean control panel for DNS and have an A record created for “@” which points at your droplet’s IP address you should just need to create a CNAME record pointing to that record:

www    CNAME    @
Submit an Answer