DNS Zone file wildcard preference

I manage my DNS settings for a domain through digital ocean. I have the following entries. *

So all subdomains route to unless I specify a specific DNS entry.

I decide to add another subdomain

I try pinging and it still resolves to

In my Zone file * is listed above pear

apple	IN A
orange	IN A
*		IN A
pear	IN A

which makes me wonder if the DNS check is matching * before it even gets a chance to see pear? For another domain, I deleted the * entry and then added it back to the end of the list and it solved my issue, but that seems a bit of a bodge to me?

Am I doing anything wrong?

Ta Chris

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Yeah that was exactly it. I’ve updated DNS entries in the past and seen the results elsewhere in minutes, but (as every DNS provider will ever tell you) I should allow for a bit longer.


As I understand the RFC (see 2.7 Wildcard records), wildcards should only match records that aren’t defined in the zone file. Is it possible that the DNS records simply hadn’t completely propagated yet?

Solved it myself. Turned out the solution was not to be an impatient moron.

Specific DNS A records always take preference over a wildcard entry